Meltdown and Spectre Vulnerabilities

Computer researchers have recently found out that the architecture in all modern CPUs has a hardware bug. Coined "Meltdown" and "Spectre", these are critical hardware-based vulnerabilities to modern processors. These vulnerabilities could allow an attacker to steal information stored in the memory of a wide range of computer chips on personal devices - this information including things such as files and passwords.

For additional details, please see the following informational site:

Engineering Innovation is actively monitoring and preparing updates to be sent out to customers to ensure this vulnerability is mitigated as best as possible. As communication from our manufacturers is still ongoing, we continue to revise our updates to take into account new files and scripts - due to the infancy of this vulnerability, many updates are still be crafting by manufacturers. 

Once updates have been finalized and have passed our internal QA measures, we will be releasing the update via our automated channels via KACE and notifying non-KACE connected customers where to go to download the necessary update to install.

We appreciate your business and look forward to keeping you safe and informed.

Engineering Innovation

Information Technology Team